Dernières versions d'ovidentia

Derniers sujets du forum


403 Access Forbidden

Aller à   
Rechercher
Auteur
Message Vue en arbre
Wilfried Schnetzler
Posté le: Jeu 09 Août 2007 14:15
Sujet de la contribution: Strange behavior of Ovidentia and PHP 5

Hello

Currently I have nine Websites running with Ovidentia 6.33 and I am very satisfied with this product!

Now my Webhost is changing from PHP 4 (4.3.10) to PHP5 (5.1.6)

Running PHP5 the Links of Ovidentia Menu are corrupted:

  1. loading the website http://msam.ch/index.php  for example all is correct
  2. but loading http://msam.ch (without index.php) the url changes to http://msam.ch// and with every click on [home] or [login] etc. it adds one / more, so you may find such strange Urls like: http://www.msam.ch/////?tg=login&cmd=signon

Changing the configuration to PHP4 it works correctly

Any Idea to fix that?

Wilfried



Haut 
samuel zebina
Posté le: Jeu 09 Août 2007 16:30
Sujet de la contribution: RE:Strange behavior of Ovidentia and PHP 5

I have just tested on your site and everything works function correctly.

What is your browser ?


Haut 
Wilfried Schnetzler
Posté le: Jeu 09 Août 2007 19:13
Sujet de la contribution: RE:Strange behavior of Ovidentia and PHP 5

Well, I have both IE7 and Mozilla Firefox and the problem is the same with both browsers

go once more to http://msam.ch oder http://www.msam.ch

Moving the mouse to [Startseite] (=home) at the top right menu you may see in the status line http://msam.ch//

If you click [Startseite] and move the mouse over [Startseite] again it has changed to http://msam.ch///
and so on...

If you now click [login] you may see http://www.msam.ch///?tg=login&cmd=signon and this URL produces an error at the login process, (Site not found, in german: Diese Website kann nicht angezeigt werden), if I go back, the login process was successful, but this is quite confusing for many user...

You may test other sites, only the url without /index.php and onliy in configuration of PHP5 has this error:

http://bachkantorei.ch (PHP5)
http://remu.ch (actually PHP4)
http://schnetzler.info (PHP4)



Haut 
Aizier Jérôme
Posté le: Ven 10 Août 2007 09:51
Sujet de la contribution: RE:Strange behavior of Ovidentia and PHP 5

I think that the problem is in the configuration of $babUrl in the config.php file.

Example of correct line :

$babUrl = "http://127.0.0.1/ovidentia-6-3-3/";



Haut 
Wilfried Schnetzler
Posté le: Mer 15 Août 2007 22:36
Sujet de la contribution: RE:Strange behavior of Ovidentia and PHP 5

No, that isn't correct with my configuration

The respective sites are on a live server, so the Variable $babURL is http://server.com/,  (this isn't the correct link, for server.com there are the respective domains)

The $babInstallPath is "ovidentia/" this is the directory with the ovidentia-core, no matter the version

I think it is a matter of the PHP_SELF variable, may be that php5 has here some difference to php4 (?)

(10 minutes later) I tried once more to solve the problem
I found this:

If with php5 $babURL is http://server.com (without the final /), it works correctly, this is a significant difference to php4

Anybody with the same problem, the same experience?

What do the competent people of ovidentia team think about?

Thanks.

---
16.08.2007: The solution I thougt having found it yesterday today dosn't work... I have to change to php4 configuration, then it works
but in december 07 this possibility will no more be available by my webhoster...

Any solution?



Modifié Jeu 16 Août 2007 12:56

Haut 
Aller à   
Rechercher
Up