Dernières versions d'ovidentia

Derniers sujets du forum



Aller à   
Rechercher
Auteur
Message Vue en arbre
Christian Malen
Posté le: Jeu 19 Janvier 2017 10:48
Sujet de la contribution: encodage utf-8 non supporté par plusieurs modules

Bonjour,

Tout d'abord merci et félicitations pour la réalisation de cet outil très utile !

Ma question : j'ai installé la version 8.4.3 et ai choisi l'encodage utf-8 pour la base de données.

Je souhaite ajouter entre autres les modules : bulletin - newsletter - questionnaire et reviewpapers.

Au moment de leur installation, la vérification faite par le système indique que l'encodage n'est pas supporté.

Est-ce que cela signifie que ces modules sont obsolètes ? sinon est-il prévu la prise en charge prochaine de utf-8 ou bien encore dois-je procéder à la conversion de la base en latin1 ?

merci pour votre éclairage,

Bien cordialement,

Christian Malen



Haut 
paul de rosanbo
Posté le: Lun 24 Avril 2017 15:57
Sujet de la contribution: RE:encodage utf-8 non supporté par plusieurs modules

Bonjour,

ces modules n'ont probablement pas été touchés depuis que la possiblité d'encoder en UTF-8 est apparue dans Ovidentia donc est effectivement on peut dire qu'ils n'ont pas été maitenu depuis un long moment, le travail qu'il reste a faire ici est de vérifier que c'est compatible avec UTF-8.

je ne conseille pas de faire machine arrière vers latin, de notre coté nous faisons tout nos nouveau site en UTF-8

si vous souhaitez mettre en oeuvre malgré tout ces anciens modules, vous pouvez modifier le fichier programs/addonini.php dans l'archive avant de le charger, il faut ajouter la ligne

mysql_character_set_database="latin1,utf8"

qui sert a indiquer les codes de caractères autorisés par contre il est possible de tomber sur des bugs car cela n'a pas été testé

Cordialement,

Paul



Haut 
Aller à   
Rechercher
Up